MacOS / Steam - "Start new Game" not working

Synchronized-turns strategy. Calling all teamers.
Post Reply
Lux Newbie
Posts: 1
Joined: Sun Sep 02, 2018 11:20 am

MacOS / Steam - "Start new Game" not working

Post by freekisanders » Sun Sep 02, 2018 11:25 am

Recently I downloaded the Lux Alliance demo and played it till max. games allowed. Everything worked
I liked it, and bought the game through Steam.
The download, etc worked. The game launches.
However, pressing "Start new game" does not launch a new game. Instead I hear the music, but no screen.

I have tried deleting the game and re-installing, however this did not help.
My guess is that the (hidden) max games allowed file from the demo is somehow retained and causes this issue.

Who has a solution, so that I can play?

User avatar
Lux Creator
Lux Creator
Posts: 11000
Joined: Thu May 15, 2003 2:01 am
Location: Cascadia

Re: MacOS / Steam - "Start new Game" not working

Post by dustin » Wed Sep 05, 2018 5:47 pm

Hmm, could you try deleting the Lux Alliance prefs file, which is located at:

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests